PPA for OpenCV 3.0 for 12.04 Precise and 14.04 Trusty

I like the idea of continuous integration testing, particularly when it’s easy. For a laugh, I thought I would try hooking my version of the AprilTags library into Travis-CI.

Unfortunately, I forgot that I was developing primarily for OpenCV 3.x, while standard Ubuntu is still using version 2.4.x. No problem, Travis allows installation from Launchpad PPAs. I’ll just, er, compile my own PPAs for OpenCV3.

So, several days (and a bazillion CPU cycles) later, I have: OpenCV 3.0.0 PPAs for Trusty and Precise. Sorry, I’ve only had time to do Precise (which Travis uses in its legacy stack) and Trusty (which I run on my compute machines) so far. Newer distos should be trivial based on Trusty…

Most importantly, I don’t know what the heck I’m doing, so if there’s something terribly wrong with them or you’d like new features, send ma pull!